Final trueSpace 7.61 Beta 8 Unofficial Update

clintonman
Captain
Posts: 2851
Joined: 21 May 2009, 21:08
Type the number ten into the box: 0
Location: California
Contact:

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by clintonman » 20 Sep 2019, 02:40

You are immediately closing model view after the restart and it crashes?
Clinton Reese

http://clintons3d.com

User avatar
trueBlue
Captain
Posts: 2106
Joined: 06 Jul 2009, 22:50
Type the number ten into the box: 10

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by trueBlue » 20 Sep 2019, 02:41

Yep

clintonman
Captain
Posts: 2851
Joined: 21 May 2009, 21:08
Type the number ten into the box: 0
Location: California
Contact:

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by clintonman » 20 Sep 2019, 02:43

Wild, not happening to me at all in that case.
I just did a test with the main window as model view and a new floating view as workspace and it did not crash.
Verifying now...

It still ran with no errors. I'm going to try running model in a larger floating window to see if that makes any difference.
Last edited by clintonman on 20 Sep 2019, 02:46, edited 1 time in total.
Clinton Reese

http://clintons3d.com

User avatar
trueBlue
Captain
Posts: 2106
Joined: 06 Jul 2009, 22:50
Type the number ten into the box: 10

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by trueBlue » 20 Sep 2019, 02:45

Here is your first test scene with your newest yaf panel.
I changed the animation a bit.
Attachments
YafModelspaceTest.RsScn
(2.85 MiB) Downloaded 5 times

clintonman
Captain
Posts: 2851
Joined: 21 May 2009, 21:08
Type the number ten into the box: 0
Location: California
Contact:

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by clintonman » 20 Sep 2019, 02:49

Just ran a test with model view full screen on second monitor and no crash.
Right now I believe a small model window is causing the crash.

Update: it refuses to crash ever since I ran model from the main window. Window size does not matter.

Reset to default context
loaded the scene
opened model small view and crash
(did same thing again and no crash)
(did same thing yet again and crash)

Reset to default context
loaded the scene
opened model main view and no crash

All tests point to using the main view for model view to avoid crashing.
Clinton Reese

http://clintons3d.com

User avatar
trueBlue
Captain
Posts: 2106
Joined: 06 Jul 2009, 22:50
Type the number ten into the box: 10

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by trueBlue » 20 Sep 2019, 03:17

You know that kind of makes sense because Workspace does not sync with Model.
Maybe you need to add some Synchronization code with your Send Keys?

clintonman
Captain
Posts: 2851
Joined: 21 May 2009, 21:08
Type the number ten into the box: 0
Location: California
Contact:

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by clintonman » 20 Sep 2019, 03:21

trueBlue wrote:
20 Sep 2019, 02:45
Here is your first test scene with your newest yaf panel.
I changed the animation a bit.
The hierarchy is a little off. Protect Workspace is a part of Model Processing. Now it looks like a separate thing.
Clinton Reese

http://clintons3d.com

clintonman
Captain
Posts: 2851
Joined: 21 May 2009, 21:08
Type the number ten into the box: 0
Location: California
Contact:

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by clintonman » 20 Sep 2019, 04:04

trueBlue wrote:
20 Sep 2019, 02:45
Here is your first test scene with your newest yaf panel.
I changed the animation a bit.
One more thing, careful about sharing scenes with modelspace special mesh enabled. If python script is not loaded into model the animation just freezes. Spent a lot of time trying to figure out why your scene refused to animate and render.
Clinton Reese

http://clintons3d.com

clintonman
Captain
Posts: 2851
Joined: 21 May 2009, 21:08
Type the number ten into the box: 0
Location: California
Contact:

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by clintonman » 20 Sep 2019, 04:05

trueBlue wrote:
20 Sep 2019, 03:17
You know that kind of makes sense because Workspace does not sync with Model.
Maybe you need to add some Synchronization code with your Send Keys?
What Send Keys are you referring too?
Clinton Reese

http://clintons3d.com

User avatar
trueBlue
Captain
Posts: 2106
Joined: 06 Jul 2009, 22:50
Type the number ten into the box: 10

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Post by trueBlue » 20 Sep 2019, 09:50

clintonman wrote:
20 Sep 2019, 02:49
All tests point to using the main view for model view to avoid crashing.
That's great!
I can confirm that this works too.

The new Yes No question about using the python script is troublesome.
As you know most of the times it is hidden behind tS61.
If you really think this is necessary, maybe you could change it to a Console Alert like you are doing with the Errors?
ConsoleFrame.PNG
ConsoleFrame.PNG (5.87 KiB) Viewed 180 times
I have uploaded your newest changes and I have changed:
YafaRay4tS.RsObj
ConvertCamera
Added:

Code: Select all

	if(Node.Exists(sel + "/Yafaray Camera Data")) {
		return;
	}

	Node.SafeRename(NewYafCamera, 'YafarayCamera')

Post Reply