Page 48 of 105

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 01:16
by clintonman
D3D Render - no longer copies to the scene and moved the display frame panel to inside the node.
Also altered the way modelspace time is set so frame 0 is not skipped and the frame is only updated 1 time per loop cycle.
No luck with removing the flashing modelside status.

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 03:07
by trueBlue
Looking good! :D
What Flashing?
If you were referring to what I was saying, I was referring to the Protect Workspace Model Status Line messages at every keyframe. :mrgreen:
Do you think a Reset Defaults script is needed?

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 03:33
by clintonman
trueBlue wrote:
19 Sep 2019, 03:07
Looking good! :D
What Flashing?
If you were referring to what I was saying, I was referring to the Protect Workspace Model Status Line messages at every keyframe. :mrgreen:
Do you think a Reset Defaults script is needed?
I don't think so. It's just 1 small panel.

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 03:36
by trueBlue
Is all of this still relevant?

Render a sequence to files
Check the Render to File
Press the Render Settings button and
uncheck "Save animation from frame"
check "Save sequence starting with"
enter a starting frame number
set the file name
press the "Save settings" button and close the dialog

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 03:51
by clintonman
trueBlue wrote:
19 Sep 2019, 03:36
Is all of this still relevant?

Render a sequence to files
Check the Render to File
Press the Render Settings button and
uncheck "Save animation from frame"
check "Save sequence starting with"
enter a starting frame number
set the file name
press the "Save settings" button and close the dialog
Yep.

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 04:21
by clintonman
YafaRay
removed Model status messages from animation render
modelspace frame set now works with frame 0 and only updates modelspace frame once per loop.

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 17:38
by trueBlue
The YafModelspaceTest.RsScn crashes trueSpace761 as soon as I close Model, after successfully rendering the 20 frame render with the included YafaRay4tS.RsObj or replacing it with the newest version.
Maybe I need to render something before I try that scene. I do remember some lag on the first render on a fresh install.
I will try that.
Edit: That did not work.
I am sure I am doing everything correctly.
Any suggestions?

Also noticed that there is still Model status messages from animation render
Also noticed that you are changing the Bridge to On.
I thought that Auto was better?

Noticed if I click on Txt res for Workspace the scene lights moved but Backup Restored them. :)
Capture.PNG
Capture.PNG (13.02 KiB) Viewed 617 times

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 19:50
by clintonman
trueBlue wrote:
19 Sep 2019, 17:38
The YafModelspaceTest.RsScn crashes trueSpace761 as soon as I close Model, after successfully rendering the 20 frame render with the included YafaRay4tS.RsObj or replacing it with the newest version.
Maybe I need to render something before I try that scene. I do remember some lag on the first render on a fresh install.
I will try that.
Edit: That did not work.
I am sure I am doing everything correctly.
Any suggestions?

Also noticed that there is still Model status messages from animation render
Also noticed that you are changing the Bridge to On.
I thought that Auto was better?

Noticed if I click on Txt res for Workspace the scene lights moved but Backup Restored them. :)
Capture.PNG
Lag is normal for the first YafaRay render of the day.
Don't see any model status from animation here.
Bridge setting is not touched by any of the code.

I've narrowed it down to the python special mesh processing. When off I get no crash when closing model window after render. If turn it on, render and closed model window I get the crash.
Maybe some tSBridge command will fix it.

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 20:41
by trueBlue
clintonman wrote:
19 Sep 2019, 19:50
Lag is normal for the first YafaRay render of the day.
Don't see any model status from animation here.
tB That's because the scene has the previous YafaRaytS panel
Bridge setting is not touched by any of the code.
tB Must have been the D3D Render then, I'll check later
I've narrowed it down to the python special mesh processing. When off I get no crash when closing model window after render. If turn it on, render and closed model window I get the crash.
Maybe some tSBridge command will fix it.
tB Yeah!!! I can confirm that.

Re: Final trueSpace 7.61 Beta 8 Unofficial Update

Posted: 19 Sep 2019, 20:45
by clintonman
Only found 1 way to stop the crash when using special mesh processing. Exit truespace after the render

I tried bridge command, flush.
bridge off - no crash, but slow crashed after reopening model view and syncing from workspace
bridge off - ... same result sync from model
new model scene after render
new workspace scene after render
undo clear and set to zero - crashed before I even got to rendering

Final conclusion:
Exit trueSpace after render is complete when using special mesh processing

Plan:
1. add warning message when using the special mesh processing
2. add camera to yafaray camera converter
3. Space.Unselect() after creation of ms_flags_object and move it out of sight
4. confirm that special mesh processing only needed for vertex animated NURBS and metaball objects to better define when to use it