Page 1 of 1

How to use V-Ray on tS76 STD ?

Posted: 23 Dec 2015, 14:41
by Emmanuel
I've made a fresh new install of tS7.61 Standalone version (no unofficial update was applied yet), and installed VRay 1.54.
VRay works : I can render a picture. But it seems I can't enter VRay's material editor.

You may know that Workspace has 2 Material Editors : one is for D3D and one is for VRay. Their panels are different. In tS7.6 and 7.61 you can switch between the two modes in the Material Editor options panel. See below a screen capture from tS7.6

But in tS7.61 Standalone, I get a crash if I try to select VRay...
TrueSpace also crashes if I try to inspect the material of an object painted with a VRay shader.

If I appy the Unofficial update 3, same problem.

Did anyone tried this ?
Is there a workaround to make VRay's material editor to work in tS Standalone version ?

Re: How to use V-Ray on tS76 STD ?

Posted: 23 Dec 2015, 16:12
by trueBlue
Its been awhile but have noticed issues with Vray when installing it. As I remember there was difficulties with the Combo Control updating and possibly duplicate Vray nodes. IE Vray and Vray, 1 and or duplicate Vray Material Editor nodes?
Search in the Link Editor for Vray and delete duplicate nodes.
Reset the Default Context and see if that helps.

Instructions for the unofficial update are as follows:
Vray users: Install/Load Vray in the Package Manager and REBOOT trueSpace.
Select the "Update Library Places" button in the D3D Material Editor. Reselect the Library Place and a Library item.

Here is a video for the Live Vray Material Editor version showing the process of updating the Library Places near the end of the video:
download/file.php?id=9110" onclick=";return false;

Re: How to use V-Ray on tS76 STD ?

Posted: 23 Dec 2015, 18:41
by stan
I just tried to install the standard and v-ray. I got the same crash. It seems to be working for a render, but not loading the editor.

Re: How to use V-Ray on tS76 STD ?

Posted: 23 Dec 2015, 19:33
by stan make it work you must copy LwME.dll from 7.61b into your std directory. Then edit your init.js with this line:RsApp.ImportPackage('LwME.dll');
I noticed that the shaders had the red around them showing they didn't work.
I uploaded the files in 7zip.

If it has any problem it's because I forgot to mention moving the LwME folder in scripts too
load the shader libraries too into the rslibrary folder.